ツイスト18.7.0にはPyHamcrest> = 1.9.0が必要ですが、これはインストールされていません。

Twisted 18 7 0 Requires Pyhamcrest 1

➜ /Users/liuzhiwei/PycharmProjects/py_code> git:(master) ✗ pip install pycryptodome Collecting pycryptodome Downloading https://files.pythonhosted.org/packages/0e/b9/6cc7e451a7b35d9151d52ee904525aa8b883489095bfc61c3d45003c4f47/pycryptodome-3.9.7-cp37-cp37m-macosx_10_6_intel.whl (14.1MB) 100% |████████████████████████████████| 14.1MB 143kB/s twisted 18.7.0 requires PyHamcrest>=1.9.0, which is not installed. Installing collected packages: pycryptodome Successfully installed pycryptodome-3.9.7 You are using pip version 10.0.1, however version 20.0.2 is available. You should consider upgrading via the 'pip install --upgrade pip' command.

twisted 18.7.0 requires PyHamcrest>=1.9.0, which is not installed.

1.対応するPyHamcrest、ダウンロードアドレスをダウンロードします。
2.Anaconda3のAnacondaプロンプトを介してインストールします
3.特定の手順:
(1)自分のCDダウンロードファイルアドレス:cd Downloads
(2)pip install PyHamcrest-1.9.0-py2.py3-none-any.whl

/Users/liuzhiwei> cd Downloads /Users/liuzhiwei/Downloads> pip install PyHamcrest-1.9.0-py2.py3-none-any.whl Looking in indexes: http://mirrors.aliyun.com/pypi/simple/ Processing ./PyHamcrest-1.9.0-py2.py3-none-any.whl Requirement already satisfied: setuptools in /Users/liuzhiwei/anaconda3/lib/python3.7/site-packages (from PyHamcrest==1.9.0) (40.2.0) Requirement already satisfied: six in /Users/liuzhiwei/anaconda3/lib/python3.7/site-packages (from PyHamcrest==1.9.0) (1.11.0) Installing collected packages: PyHamcrest Successfully installed PyHamcrest-1.9.0 You are using pip version 10.0.1, however version 20.0.2 is available. You should consider upgrading via the 'pip install --upgrade pip' command. ➜