アクセサーは、ECMAScript5以降のエラーメッセージを対象とする場合にのみ使用できます。

Accessors Are Only Available When Targeting Ecmascript 5

ここに来るということは、賢くて勤勉なあなたが、JavaScriptの大きなクラスターであるTypescriptを学んでいるに違いないということを意味します。幸い、コードの記述は完了です。結果は次のとおりです。

- error TS1056: Accessors are only available when targeting ECMAScript 5 and higher.

おそらく、バージョンES5以降にコンパイルする必要があることを意味します
つまり、バージョンES5以降にコンパイルする必要があります
次に、次のように指定します。



tsc project name.ts -t es5 // Such as tsc class.ts -t es5

正常に実行され、set / getメソッドを楽しく記述し続けます

If you have any questions, please leave a message or add V chinaynlmq