pycharmでpipをアップグレードした後でも、問題を更新する必要があります。



After Upgrading Pip Pycharm

この問題は何度も発生しており、次回は記録しておくと便利です。

これはエラーメッセージです(設定が設定された後もこのエラーは通知されます)



You are using pip version 10.0.1, however version 19.0.3 is available. You should consider upgrading via the 'python -m pip install --upgrade pip' command.

解決
untitled1 venv Lib site-packagesディレクトリで、pip-19.0.3.dist-infoと以前のpipバージョンを削除します。
再実行

python -m pip install --upgrade pip

結果はエラーメッセージなしで正常にアップグレードされました